wiki:Requirements

Requirements

Webserver

Any webserver capable of interpreting PHP files. Ideally, this webserver is capable of URL rewriting (Apache, lighttpd).

PHP

At least version 5.1

Database

An SQL database server / system. Currently, SQLite (at least version 3) and MySQL (at least version 4) are supported. Support for others can easily be added, provided they can be accessed via PHP's PDO.


The main development system runs Debian GNU/Linux, Apache 2 and SQLite. In theory, Spam Board should also run on Microsoft Windows, but that hasn't been tested (feel free to edit this if you do).

Last modified 9 years ago Last modified on 11/30/07 16:27:53